Back to overview
Resolved
Website wont update
Feb 3, 2026 at 3:38pm UTC
Affected services
empo.cc
Website
Web
Resolved
Feb 3, 2026 at 3:38pm UTC
Update: Resolved. Works as intended now!
Update: We notified the Host about the Problem
The website dosent update the html
Affected services